const regex = new RegExp('[^\\:]+:([\\d\\s]+\\s\\s).*', 'gm')
const str = `0000000: 01010000 01001011 00000011 00000100 00010100 00000011 PK....
0000006: 00000000 00000000 00001000 00000000 01000000 10001101 ....@.
000000c: 00101001 01000110 10011111 00101100 00000001 11100100 )F.,..
0000012: 01111100 00101011 00000000 00000000 10111110 11010111 |+....
0000018: 00000010 00000000 00001101 00000000 00000000 00000000 ......
000001e: 01110000 01100001 01101110 01100100 01100001 01011111 panda_
0000024: 01100010 01101001 01101110 00101110 01110100 01111000 bin.tx
000002a: 01110100 10101100 10011010 01001001 10101110 10011011 t..I..
0000030: 01010000 00010000 01000101 11100111 01011001 10000101 P.E.Y. `;
const subst = `$1\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);