const regex = /^\x3a(?::?(?:\[\w+\])?(?:\[\s\w+\s\]?)?)?\s?(\w+)/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\x3a(?::?(?:\\[\\w+\\])?(?:\\[\\s\\w+\\s\\]?)?)?\\s?(\\w+)', 'gim')
const str = `:[ Admin ] User_name
:[gold][ Admin ] User_name
:[gold]User_name
:[gold][ Admin ] user_name
:User_name`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}