using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ORDER BY.*?(?=\)|$)";
string substitution = @"";
string input = @"SELECT * FROM table ORDER BY name
SELECT a.* FROM (SELECT * FROM table ORDER BY name, creation_date) AS a ORDER BY a.name";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}