$re = '/(?<=;)(?![^{]*})|(?<=}(?!$))/m';
$str = 'a;b{c;d;}e{f;}';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;