package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^?][PG]$|<|PG`)
var str = `PPCG
^P
^[P^]P
[^?][PG]$
(?<!\\..)(?!]).$
[PPCG]
^[P\^]
[^\]]$
^\^?P`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}