# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b\s+\b/ /gm;t' <<< "One OS to rule them all,
One OS to find them.
One OS to call them all,
And in salvation bind them.
In the bright land of Linux,
Where the hackers play."