# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?s)((?<=^#BeginEntries\n).*?(?=\n#EndEntries$))/Success!/gm;t' <<< "#BeginEntries
This is a test
#EndEntries
"