const regex = /(?:(.)(?=(.*)\1))/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(.)(?=(.*)\\1))', 'igm')
const str = `sTress
lambda
moonmen`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);