$re = '/^\d{1,2}(\.\d{1,5})?$/m';
$str = 'Please help me with a regular expression in javascript which takes one or two digits before decimal point and optional or max five digits after decimal point .Possible values are 12.345
12.12
1.3
1.12345
12
1
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);