re = /\p{Latin}+(?:\h*\p{Latin}+)*(?=\h*\p{Cyrillic}+)/m
str = 'Один два три apple orange yellow четыре пять black white'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end