package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*(\d{4})`)
var str = `ABC123456789A9876
ABCD1234567890F23
1234ABC4567JIJLMN
ABCDEFG1234-!.567
12345660703J1A501F4Z2051
1234ABCLDlZd1523
1234ABCLDlZd15
ABC1234
ABC1234ABC1234A
ABC123ABC123A`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}