import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*(\\d{4})";
final String string = "ABC123456789A9876\n"
+ "ABCD1234567890F23\n"
+ "1234ABC4567JIJLMN\n"
+ "ABCDEFG1234-!.567\n"
+ "12345660703J1A501F4Z2051\n"
+ "1234ABCLDlZd1523\n"
+ "1234ABCLDlZd15\n"
+ "ABC1234\n"
+ "ABC1234ABC1234A\n"
+ "ABC123ABC123A";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}