$re = '/.*(\d{4})/m';
$str = 'ABC123456789A9876
ABCD1234567890F23
1234ABC4567JIJLMN
ABCDEFG1234-!.567
12345660703J1A501F4Z2051
1234ABCLDlZd1523
1234ABCLDlZd15
ABC1234
ABC1234ABC1234A
ABC123ABC123A';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);