// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(<\w+)(\s*[\w-]+="[^"]+")*(\s*data-toggle="[^"]+")(\s*[\w-]+="[^"]+")*(\s*>)"#).unwrap();
let string = "<td class=\"sky\" data-toggle=\"up\" id=\"heaven\" >
<td class=\"sky\" data-toggle=\"up\" id=\"heaven\" >
<td class=\"sky\" data-toggle=\"up\" id=\"heaven\" >
<td class=\"sky\" data-toggle=\"up\" id=\"heaven\" >
<td class=\"sky\" data-toggle=\"up\" id=\"heaven\" >
<td class=\"sky\" data-toggle=\"up\" id=\"heaven\" >
<td class=\"sky\" data-toggle=\"up\" id=\"heaven\" >
<td class=\"sky\" data-toggle=\"up\" id=\"heaven\" >
<a href=\"#\" data-toggle=\"modal\" data-target=\"xxxx\"></a>
<a href=\"#\"data-target=\"#available-assistance\" data-toggle=\"modal\" data-modal=\"yeah\"></a>
<a href=\"#\"data-target=\"#available-assistance\" data-toggle=\"modal\" data-modal=\"yeah\"></a>
";
let substitution = "$1$3$5";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}