using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-z])(\1{0,1})\1*";
string substitution = @"$1$2";
string input = @" Helloooooo my frieeend!!!What are you doing?? Tell me what you like...........,please.
";
RegexOptions options = RegexOptions.CultureInvariant;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}