$re = '/(^|#)9\|(4[,#]|([\d]+,)+4[,#])/';
$str = '7|1#9|1,5,7#10|2,4,51#
7|1#9|1,4,5#10|1,3,38#';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);