re = /\S+\s+\S+\s+\S+\s+\S+\s+\S+\s+\S+\s+\S+\s+\S+\s+(.*)/
str = 'drwxrwxr-x 2 bhannan bhannan 4096 Jun 2 11:27 HelloWorld.xml'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end