// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\w+):").unwrap();
let string = "{ query: { and: [ { and: [ { _t: \"Manifest\" }, { or: [ { and: [ { _i: { gt: \"53b2616fe4b028359ac3fea4\" } } ] } ] }, { _s: \"active\" } ] }, { ENu_v: { elemMatch: { EOJ_v: { in: [ \"*\", \"Production\", \"QA \" ] } } } } ] }, orderby: { _i: 1 } }";
let substitution = "\"\\1\":";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}