re = /^(\d{2})(\s?)(9?\d{4})(-?)\d{4}/m
str = '11 8765-1234
11 98765-1234
118765-1234
11 87651234
11987651234
119876512345 = muitos números não validaria
11876541234 = muitos números sem o 9 também não validaria.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end