const regex = /(\d{10})|(\d{3}-\d{3}-\d{4})|(\(\d{3}\)\d{3}-\d{4})
/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{10})|(\\d{3}-\\d{3}-\\d{4})|(\\(\\d{3}\\)\\d{3}-\\d{4})
', 'g')
const str = `(888)123-3456
8881231234
888-123-1234
888-1234567`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}