re = /(\d{10})|(\d{3}-\d{3}-\d{4})|(\(\d{3}\)\d{3}-\d{4})
/
str = '(888)123-3456
8881231234
888-123-1234
888-1234567'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end