#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([1-9]\d{0,3}|1\d{4}|20000)$"
Local $sString = "50001" & @CRLF & _
"10000" & @CRLF & _
"1" & @CRLF & _
"10" & @CRLF & _
"100" & @CRLF & _
"1000" & @CRLF & _
"10000" & @CRLF & _
"19999" & @CRLF & _
"20000" & @CRLF & _
"20001"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")