package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?:<strong\b[^>]*>(?<name>.*?)<\/strong>|"myspecialaction\?.*?list=(?<id>[^&"]+))`)
var str = `table>
<tr>
<td><strong>Name 1</strong></td>
<td>Info and ignore <a href="/gohere"/>this</a></td>
<td><a href="MySpecialAction?list=10000">Edit</a></td>
</tr>
<tr>
<td><strong>Name 2</strong></td>
<td>Info and ignore <a href="/gohere"/>this</a></td>
<td><a href="MySpecialAction?field=&list=10001">Edit</a></td>
</tr>
<tr>
<td><strong>Name 2</strong></td>
<td>Info and ignore <a href="/gohere"/>this</a></td>
<td><a href="MySpecialAction?field=&list=10002&something=whatever">Edit</a></td>
</tr>
</table>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}