use strict;
my $str = 'table>
<tr>
<td><strong>Name 1</strong></td>
<td>Info and ignore <a href="/gohere"/>this</a></td>
<td><a href="MySpecialAction?list=10000">Edit</a></td>
</tr>
<tr>
<td><strong>Name 2</strong></td>
<td>Info and ignore <a href="/gohere"/>this</a></td>
<td><a href="MySpecialAction?field=&list=10001">Edit</a></td>
</tr>
<tr>
<td><strong>Name 2</strong></td>
<td>Info and ignore <a href="/gohere"/>this</a></td>
<td><a href="MySpecialAction?field=&list=10002&something=whatever">Edit</a></td>
</tr>
</table>';
my $regex = qr/(?:<strong\b[^>]*>(?<name>.*?)<\/strong>|"myspecialaction\?.*?list=(?<id>[^&"]+))/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}