re = /(([^0-9][0-9]{0,9})*)(\b[0-9]{10}\b)(([0-9]{0,9}[^0-9])*)/
str = 'a12 1449158360 foo 1449158360 bar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end