# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d).*(?=\s*;[s|S]erial)"
test_str = ("$TTL 10800\n"
"@ IN SOA foreman.quicksand.identix.com. root.quicksand.identix.com. (\n"
" 1 ;Serial\n"
" 86400 ;Refresh\n"
" 3600 ;Retry\n"
" 604800 ;Expire\n"
" 3600 ;Negative caching TTL\n"
")\n\n"
"@ IN NS foreman.quicksand.identix.com.\n\n"
"foreman.quicksand.identix.com. IN A 10.32.111.100\n\n")
subst = "$1\\t"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.