const regex = /title="([a-z]+)"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('title="([a-z]+)"', 'g')
const str = `<a title="Fruit" href="cate1.html" data-type="cate" />
<a title="apple" href="article1.html" data-type="article" />
<a title="orange" href="article2.html" data-type="article" />
<a title="Vegetable" href="cate2.html" data-type="cate" />
<a title="cabbage" href="article3.html" data-type="article" />`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}