const regex = /^([^\]]+)]\s(?<Warning>.*)\suser:\s(?<user>[^ ]*)\s([^\(]*)\((?<message>[\w\s]*)\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^\\]]+)]\\s(?<Warning>.*)\\suser:\\s(?<user>[^ ]*)\\s([^\\(]*)\\((?<message>[\\w\\s]*)\\)', 'gm')
const str = `2023-02-10 13:01:59 30 [Warning] Aborted connection 30 to db: 'unconnected' user: 'unauthenticated' host: '172.17.0.1' (This connection closed normally without authentication)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}