re = /\b.*\p{Lu}.*\p{Lu}.*\b/m
str = 'eHJHJK
YUIYUI
LkfjkdJkdfj
LLdkjkd
OhdfjhdsjO
LLLuoiu9898
Ohdf&jh/dsjO
auuuu
JJJJJJJJ
YYYY99999
ooooPPPP'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end