$re = '/(?:\b| )([.,:;!]+)(?: |\b)/m';
$str = 'Hi!stack overflow... is a popular website, I visit it every day.
aaa...
AAA...BBB
AA .BBB #unlikely to happen but managed anyway
Test smilyeys :) :D -.- #One is done, Here the D can\'t be avoided';
$subst = " \1 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;