import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<p>|<div .*>)(\\s*)(<a .*>)?(\\s*)(<img .* \\/>)(\\s*)(<\\/a>)?(\\s*)(<p .*>.*<\\/p>)?(\\s*)(<\\/p>|<\\/div>)";
final String string = "<div id=\"attachment_3340\" style=\"width: 865px\" class=\"wp-caption alignnone\">\n"
+ " <img class=\"size-full wp-image-3340\" alt=\"Testbild\" src=\"https://beispiel.de/images/Testbild.jpg\" width=\"855\" height=\"631\" />\n"
+ " <p class=\"wp-caption-text\">© Copyright</p>\n"
+ "</div>";
final String subst = "$3$5$7$9";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}