// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^/(panel|api)(/|\?|$)").unwrap();
let string = "/panel
/panel/test
/panel?test
/panelpage
/panel-page
/panel24
/blog/panel";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}