using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"v=([-\w]+)";
string input = @"http://www.youtube.com/watch?v=3YDz-ftqr1g ";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}