package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"(?:\\"|\\\\|[^"])*"|\S+`)
var str = `compile test.json output.bin -location "Paris, France" -author "Charles \"Demurgos\"" "windowsDirectory\\" "otherArg"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}