using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s+Content-[Tt]ype:\s*\S+";
string input = @"Accept-Ranges: bytes
Cache-Control: max-age=604800
Content-Type: text/html
Date: Fri, 14 Aug 2015 17:45:05 GMT
Etag: ""359670651""
Expires: Fri, 21 Aug 2015 17:45:05 GMT
Last-Modified: Fri, 09 Aug 2013 23:54:35 GMT
Server: ECS (fty/2FA4)
X-Cache: HIT
x-ec-custom-error: 1
Content-Length: 1270
- 0%[ ] 0 --.-KB/s <!doctype html>
<html>
<head>
<title>Example Domain</title>
<meta charset=""utf-8"" />
<meta http-equiv=""Content-type"" content=""text/html; charset=utf-8"" />
<meta name=""viewport"" content=""width=device-width, initial-scale=1"" />
<style type=""text/css"">
body {
background-color: #f0f0f2;
margin: 0;
padding: 0;
font-family: ""Open Sans"", ""Helvetica Neue"", Helvetica, Arial, sans-serif;
}
div {
width: 600px;
margin: 5em auto;
padding: 50px;
background-color: #fff;
border-radius: 1em;
}
a:link, a:visited {
color: #38488f;
text-decoration: none;
}
@media (max-width: 700px) {
body {
background-color: #fff;
}
div {
width: auto;
margin: 0 auto;
border-radius: 0;
padding: 1em;
}
}
</style>
</head>
<body>
<div>
<h1>Example Domain</h1>
<p>This domain is established to be used for illustrative examples in documents. You may use this
domain in examples without prior coordination or asking for permission.</p>
<p><a href=""http://www.iana.org/domains/example"">More information...</a></p>
</div>
</body>
</html>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}