$re = '/Notif\[\d+\][^NF]*(?:(?:N(?!otif)|F(?!inish))[^NF]*)*/s';
$str = 'Notif[0]:
some text multiple line
Notif[1]:
multiple line text
Notif[2]:
text again
Notif[3]:
text again
Finish';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);