#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)([a-zA-Z0-9]*):\s*\(([a-zA-Z0-9.]*)\)\s*\{(.*?)\}"
Local $sString = "TargetUPS: (java.lang.Integer) "200"" & @CRLF & _
"TargetFPS: (java.lang.Integer) "60"" & @CRLF & _
"DebugID: (java.lang.Character) "s"" & @CRLF & _
"MainCamera: (game.gameObject.graphics.Camera) {" & @CRLF & _
" (java.awt.geom.Rectangle2D.Float) {" & @CRLF & _
" (java.lang.Integer)"0"" & @CRLF & _
" (java.lang.Integer)"0"" & @CRLF & _
" (java.lang.Integer)"800"" & @CRLF & _
" (java.lang.Integer)"600")" & @CRLF & _
" }," & @CRLF & _
" (game.screen.ScreenRect) {" & @CRLF & _
" (java.lang.Integer)"0"" & @CRLF & _
" (java.lang.Integer)"0"" & @CRLF & _
" (java.lang.Integer)"1"" & @CRLF & _
" (java.lang.Integer)"1"" & @CRLF & _
" }, " & @CRLF & _
" (java.awt.Color) {" & @CRLF & _
" (java.lang.Integer)"0"" & @CRLF & _
" (java.lang.Integer)"255"" & @CRLF & _
" (java.lang.Integer)"0"" & @CRLF & _
" }" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")