#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d+(?:,\d+)*(?:\.\d|\.\d\d)?$"
Local $sString = "1" & @CRLF & _
"1.0" & @CRLF & _
"1.00" & @CRLF & _
"100.00" & @CRLF & _
"1,000.00" & @CRLF & _
"1000.00" & @CRLF & _
"111,000.00" & @CRLF & _
"111000.00" & @CRLF & _
"999,999,999.00" & @CRLF & _
"999,999,999,999.00" & @CRLF & _
"" & @CRLF & _
",1.00" & @CRLF & _
"1." & @CRLF & _
"1,,00.00" & @CRLF & _
"1.000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")