// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d+(?:,\d+)*(?:\.\d|\.\d\d)?$").unwrap();
let string = "1
1.0
1.00
100.00
1,000.00
1000.00
111,000.00
111000.00
999,999,999.00
999,999,999,999.00
,1.00
1.
1,,00.00
1.000";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}