# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^-]+)-([^-]+)-([^-]+)/word1 - word2 - word3 from $3, $2, $1/gm;t' <<< "Mavis Dracula - ZZ - 001.jpg"