#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([^-]+)-([^-]+)-([^-]+)"
Local $sString = "Mavis Dracula - ZZ - 001.jpg"
Local $sSubst = "word1 - word2 - word3 from $3, $2, $1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)