use strict;
my $str = 'Mavis Dracula - ZZ - 001.jpg';
my $regex = qr/([^-]+)-([^-]+)-([^-]+)/mp;
my $subst = 'word1 - word2 - word3 from $3, $2, $1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";