#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)key: \'(.*?)\',\s*$"
Local $sString = " var newEncryptMode = ''" & @CRLF & _
" var Encrypt = {" & @CRLF & _
" key: 'a2ffa5c9be07488bbb04a3a47d3c5f6a'," & @CRLF & _
" iv: '64175472480004614961023454661220'," & @CRLF & _
" nonce: null," & @CRLF & _
" init: function () {" & @CRLF & _
" var nonce = this.nonceCreat();" & @CRLF & _
" this.nonce = nonce;" & @CRLF & _
" return this.nonce;" & @CRLF & _
" }," & @CRLF & _
" nonceCreat: function () {" & @CRLF & _
" var type = 0;" & @CRLF & _
" var deviceId = 'f8:b4:6a:aa:5d:96';" & @CRLF & _
" var time = Math.floor(new Date().getTime() / 1000);" & @CRLF & _
" var random = Math.floor(Math.random() * 10000);" & @CRLF & _
" return [type, deviceId, time, random].join('_');" & @CRLF & _
" }," & @CRLF & _
" oldPwd: function (pwd) {" & @CRLF & _
" if(newEncryptMode == 1){" & @CRLF & _
" return CryptoJS.SHA256(this.nonce + CryptoJS.SHA256(pwd + this.key).toString()).toString();" & @CRLF & _
" }else{" & @CRLF & _
" return CryptoJS.SHA1(this.nonce + CryptoJS.SHA1(pwd + this.key).toString()).toString();" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" },"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")