$re = '/\^(\((([^()]|(?1))*)\))/m';
$str = 'a^(x²)
b^(-(x²)+(y+(a+b)))
b^(-(x²)+(y+(a+b)))';
$subst = "^{$2}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;