#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=(?:.*[A-Z].*){2})(?!(?:.*[A-Z].*){3,})(?=(?:.*\d.*){3})(?!(?:.*\d.*){4,}).*$"
Local $sString = "HelLo1aa2s3d: true " & @CRLF & _
"WindowA1k2j3: true " & @CRLF & _
"Asjs21js1: false" & @CRLF & _
"ASaaak12: false" & @CRLF & _
"AAAsjs21js1: false" & @CRLF & _
"AA123" & @CRLF & _
"AAA123" & @CRLF & _
"1234AA"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")