re = /^(?=(?:.*[A-Z].*){2})(?!(?:.*[A-Z].*){3,})(?=(?:.*\d.*){3})(?!(?:.*\d.*){4,}).*$/m
str = 'HelLo1aa2s3d: true
WindowA1k2j3: true
Asjs21js1: false
ASaaak12: false
AAAsjs21js1: false
AA123
AAA123
1234AA'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end