import re
regex = re.compile(r"(\d+:\d+:\d+\.\d+)\s+(\S+):\s+(\d+:\d+:\d+\.\d+)\s+op:\s+(\S+)\s+lun:\s+(\/\S+\/\S+)\s+lba:\s+(\d+)\s+0x[0-9A-F]+\s+xfer:\s+(\d+)\s+errno:\s+EIO:\s+'I/O error'$")
test_str = "12:57:57.092 localhost-3: 12:57:57.049 op: write lun: /dev/sdd lba: 15229894656 0x38BC5C000 xfer: 8192 errno: EIO: 'I/O error'"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")