# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/,?\+\d+_[^,]+//g;t' <<< "+1223,+12_remove_me,+222,+2223_remove_me"