#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ",?\+\d+_[^,]+"
Local $sString = "+1223,+12_remove_me,+222,+2223_remove_me"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)