use strict;
my $str = '+1223,+12_remove_me,+222,+2223_remove_me';
my $regex = qr/,?\+\d+_[^,]+/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";